← Back to Weekly Roundup
Weekly Roundup2026-10-19 β€” 2026-10-25

Weekly Vulnerability Roundup β€” October 19 to 25, 2026

This week’s roundup covers 15 notable CVEs tracked between 2026-10-19 and 2026-10-25. No new KEV additions this week. Top affected vendors: dataease, nikhil-bhalerao, tecrail.

Critical Highlights

CRITICALCVE-2020-21012CVSS 9.8

nikhil-bhalerao hotel and lodge management system

Sourcecodester Hotel and Lodge Management System 2.0 is vulnerable to unauthenticated SQL injection and can allow remote attackers to execute arbitrary SQL commands via the email parameter to the edit

Attack Vector: NETWORKCWE: CWE-89
Mitigation: Immediately restrict access to the Hotel and Lodge Management System and apply the latest security patches or updates from the vendor to remediate the unauthenticated SQL injection vulnerability.
CRITICALCVE-2022-44276CVSS 9.8

tecrail responsive filemanager

In Responsive Filemanager < 9.12.0, an attacker can bypass upload restrictions resulting in RCE.

Attack Vector: NETWORKCWE: CWE-434
Mitigation: Upgrade Responsive Filemanager to version 9.12.0 or newer to address the upload restriction bypass leading to Remote Code Execution.
CRITICALCVE-2023-23080CVSS 9.8

tenda it7-lcs firmware

Certain Tenda products are vulnerable to command injection. This affects Tenda CP7 Tenda CP7<=V11.10.00.2211041403 and Tenda CP3 v.10 Tenda CP3 v.10<=V20220906024_2025 and Tenda IT7-PCS Tenda IT7-PCS<

Attack Vector: NETWORKCWE: CWE-77
Mitigation: Update Tenda CP7 firmware to V11.10.00.2211041403 or later, and Tenda CP3 v.10 firmware to the latest available version to mitigate command injection vulnerabilities.

Full Digest

CRITICALCVE-2023-25207CVSS 9.8prestashop dpd france

PrestaShop dpdfrance <6.1.3 is vulnerable to SQL Injection via dpdfrance/ajax.php. β€” Update the PrestaShop dpdfrance module to version 6.1.3 or higher to patch the SQL Injection vulnerability in ajax.php.

CRITICALCVE-2023-30191CVSS 9.8cdesigner project cdesigner

PrestaShop cdesigner < 3.1.9 is vulnerable to SQL Injection via CdesignerTraitementModuleFrontController::initContent(). β€” Upgrade the PrestaShop cdesigner module to version 3.1.9 or later to fix the SQL Injection vulnerability.

CRITICALCVE-2025-58045CVSS 9.8dataease dataease

Dataease is an open source data analytics and visualization platform. In Dataease versions up to 2.10.12, the patch introduced to mitigate DB2 JDBC deserialization remote code execution attacks only b β€” Upgrade Dataease to a version beyond 2.10.12 to ensure proper mitigation of the DB2 JDBC deserialization vulnerability.

CRITICALCVE-2025-58748CVSS 9.8dataease dataease

Dataease is an open source data analytics and visualization platform. In Dataease versions up to 2.10.12 the H2 data source implementation (H2.java) does not verify that a provided JDBC URL starts wit β€” Update Dataease to a version past 2.10.12 to address the H2 data source deserialization vulnerability.

CRITICALCVE-2025-59431CVSS 9.8osgeo mapserver

MapServer is a system for developing web-based GIS applications. Prior to 8.4.1, the XML Filter Query directive PropertyName is vulnerably to Boolean-based SQL injection. It seems like expression chec β€” Upgrade MapServer to version 8.4.1 or newer to resolve the Boolean-based SQL injection vulnerability in the XML Filter Query directive PropertyName.

CRITICALCVE-2025-64163CVSS 9.8dataease dataease

DataEase is an open source data visualization analysis tool. In versions 2.10.14 and below, the vendor added a blacklist to filter ldap:// and ldaps://. However, omission of protection for the dns:// β€” Update DataEase to a version beyond 2.10.14 to implement robust filtering for LDAP connections and prevent potential bypasses.

CRITICALCVE-2025-64164CVSS 9.8dataease dataease

Dataease is an open source data visualization analysis tool. In versions 2.10.14 and below, DataEase did not properly filter when establishing JDBC connections to Oracle, resulting in a risk of JNDI i β€” Upgrade DataEase to a version past 2.10.14 to ensure proper filtering and secure establishment of JDBC connections, preventing deserialization attacks.

CRITICALCVE-2026-12481CVSS 9.8keras keras

A vulnerability in keras-team/keras version 3.14.0 allows for arbitrary code execution due to improper handling of deserialization in the `Lambda` layer. Specifically, the `_raise_for_lambda_deseriali β€” Update Keras to a version beyond 3.14.0, or avoid using the `Lambda` layer with untrusted inputs, to prevent arbitrary code execution via deserialization.

CRITICALCVE-2026-34977CVSS 9.8aperisolve aperisolve

Aperi'Solve is an open-source steganalysis web platform. In versions 3.1.3 through 3.2.0, when uploading a JPEG, a user can specify an optional password to accompany the JPEG. This password is then di β€” Upgrade Aperi'Solve to a version beyond 3.2.0 to mitigate the command injection vulnerability when processing JPEG files with passwords.

CRITICALCVE-2026-42238CVSS 9.8nginxui nginx ui

Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.8, nginx-ui exposes a backup restore endpoint (POST /api/restore) that is completely unauthenticated during the first 10 β€” Update Nginx UI to version 2.3.8 or higher to secure the backup restore endpoint and prevent unauthorized file uploads and code execution.

CRITICALCVE-2026-48939CVSS 9.8joomlic icagenda

A vulnerability in the iCagenda extension for Joomla allows the upload of arbitrary files in the file attachment feature, ultimately resulting in PHP code upload and execution. β€” Update the iCagenda extension for Joomla to the latest patched version to prevent arbitrary file uploads and subsequent PHP code execution.

CRITICALCVE-2026-56290CVSS 9.8joomlack page builder ck

Joomla Extension - joomlack.fr - Unauthenticated file upload in Page Builder CK extension < 3.6.0 - The Joomla extension Page Builder CK is vulnerable to an unauthenticated arbitrary file upload that β€” Upgrade the Joomla Page Builder CK extension to version 3.6.0 or newer to remediate the unauthenticated file upload vulnerability.

Themes & Observations

This week's roundup highlights a persistent, concerning trend: an overwhelming prevalence of basic, easily preventable vulnerabilities in widely used applications. SQL injection (CWE-89) dominates, appearing in multiple critical-rated CVEs across disparate platforms, from hotel management systems to e-commerce plugins and GIS software. This isn't sophisticated zero-day stuff; it's fundamental input validation failure. Beyond SQLi, we see critical issues like unrestricted file upload (CWE-434) and command injection (CWE-77), alongside server-side request forgery (CWE-918) and deserialization flaws (CWE-502) in the DataEase platform. The common thread is a clear lack of secure development practices and insufficient security testing in the SDLC. We're dealing with a foundational problem here, not just isolated bugs. This suggests a systemic issue with how many vendors approach security from the ground up.

This roundup is generated using ComplyIT’s composite scoring methodology that weighs CISA KEV status, CVSS base scores, exploit availability, vendor impact, and CWE prevalence. Learn more about our methodology.